Hatena::Grouptech

id:rx7(@namikawa)の技術メモ このページをアンテナに追加 RSSフィード

過去記事一覧 | Main Blog (元RX-7乗りの適当な日々) | SBM (id:rx7のBookmark)

2015/07/31

net-ssh requires Ruby version >= 2.0.

| net-ssh requires Ruby version >= 2.0. - id:rx7(@namikawa)の技術メモ を含むブックマーク はてなブックマーク - net-ssh requires Ruby version >= 2.0. - id:rx7(@namikawa)の技術メモ net-ssh requires Ruby version >= 2.0. - id:rx7(@namikawa)の技術メモ のブックマークコメント

# gem install capistrano
Fetching: net-ssh-3.0.1.gem (100%)
ERROR:  Error installing capistrano:
        net-ssh requires Ruby version >= 2.0.

最新の Capistrano をインストールしようとしたら、Ruby 1.9系だと最新の net-ssh が使えない、と。

まー、そうですよねーーー。


# gem install net-ssh -v 2.9.2
Fetching: net-ssh-2.9.2.gem (100%)
Successfully installed net-ssh-2.9.2
1 gem installed


# gem install capistrano

・・・・・省略・・・・・

Successfully installed capistrano-3.4.0
6 gems installed

ということで、下記のページで net-ssh の全バージョンを新しい順から、Ruby 1.9 で使えそうなものを入れた。

トラックバック - http://tech.g.hatena.ne.jp/rx7/20150731